Saturday, April 5, 2008

How to run Firefox 3 Beta 4, beta 5, and later build on Stock EEE PC 701

EEEPC 701 has ASUS Linux (a derivation of Xandros) pre-installed. It has gtk 2.8 and very difficult to update it to gtk 2.10+ which is required by firefox 3 beta 4, beta 5 or, presumably, final version.

Here is a work around that requires no installation of any packages, very safe way to run firefox beta 4, beta 5 on stock EEEPC 701.

This method is derived from this discussion at mozillazine.org

1. download gtk 2.10, bring up a terminal by pressing ctrl+atl+T, type this code and press enter
wget http://apt.linex.org/linex/gtk-2.10/libgtk2.0-0_2.10.13-2~bpo.1_i386.deb

2. extract it to a folder, e.g., gtk2-10, by type this code and press enter

dpkg-deb -x libgtk2.0-0_2.10.13-2~bpo.1_i386.deb gtk2-10

3. download firefox 3 (now in beta 5) http://www.mozilla.com/en-US/firefox/all-beta.html

4. extract firefox 3 in file manager

5. go into the firefox folder, open firefox (scrip file in the folder, about 3.9KB in size) with text editor.

6. add "export LD_LIBRARY_PATH="/home/user/gtk2-10/usr/lib" after first line. the file should look like this

#!/bin/sh
#
export LD_LIBRARY_PATH="/home/user/gtk2-10/usr/lib"
...

7. save the file, double click it to start firefox 3.



This is how it looks like, Enjoy




Technorati Tags: , ,

2 comments:

Alexey Karguine said...

Thanks a lot! It works great!

Ron said...

Add an extra step:

Copy the plugins from the old installation of Firefox to the new installation.

The old plugins work just fine with Firefox3 (as far as I've been able to test).

If you don't copy over the plugins, things like Flash won't work and you'll get popups asking you to install plugins.